<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"><html lang="en"><!--[if lt IE 7]><html lang="en" class="ie6"><![endif]--><!--[if IE 7]><html lang="en" class="ie7"><![endif]--><!--[if IE 8]><html lang="en" class="ie8"><![endif]--><!--[if IE 9]><html lang="en" class="ie9"><![endif]--><!--[if (gt IE 9)|!(IE)]><html lang="en"><![endif]--><head><META http-equiv="Content-Type" content="text/html; charset=utf-8"><!--Customized Stylesheet Includes - prehead--><!--Customized JS Includes - prehead--><title>Hometown Proud and Fun - NBC Right Now/KNDO/KNDU Tri-Cities, Yakima, WA |</title>
<meta name="Description" content="NBC Right Now will provide all your local Yakima, Tri-Cities, Walla Walla and Hermiston news, weather and sports. "><meta name="KEYWORDS" content="nbcrightnow,kndo.com,KNDO,local News,Yakima News, Yakima Valley,kndu.com, KNDU,Tri-Cities News,Kennewick,Richland,West Richland,Pasco, Walla Walla, Hermiston News,Weather forecast,local sports,sports."><meta name="news_keywords" content="nbcrightnow,kndo.com,KNDO,local News,Yakima News, Yakima Valley,kndu.com, KNDU,Tri-Cities News,Kennewick,Richland,West Richland,Pasco, Walla Walla, Hermiston News,Weather forecast,local sports,sports."><meta name="ROBOTS" content="index,follow,noarchive"><meta name="date" content="2016/05/20"><meta name="owner" content="KNDU"><meta name="wn-version" content="ContainerE-Category"><meta name="wn-build" content="7.9.1.1"><meta name="wn-base" content="IIS07"><meta name="wnreadableurl" content="hometown-proud-and-fun"><meta property="og:title" content="Hometown Proud and Fun"><meta property="og:type" content="article"><meta property="og:url" content="http://www.nbcrightnow.com/category/314647/hometown-proud-and-fun"><meta property="og:image" content="http://kndu.images.worldnow.com/images/16692766_G.png"><meta property="og:description" content="NBC Right Now will provide all your local Yakima, Tri-Cities, Walla Walla and Hermiston news, weather and sports. "><link rel="canonical" href="http://www.nbcrightnow.com/category/314647/hometown-proud-and-fun"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Hometown Proud and Fun"><meta name="twitter:description" content="NBC Right Now will provide all your local Yakima, Tri-Cities, Walla Walla and Hermiston news, weather and sports. "><meta name="twitter:image" content="http://kndu.images.worldnow.com/images/16692766_G.png"><!--Customized Page Includes - Meta-->
<!--
                Page Include: META--><meta name="google-site-verification" content="Q1JQFBem_hWya77BolCVfZevFGBSk0ME7w5FbxEy9PM" /><meta property="fb:app_id" content="1458431541046455" /><!--
                END Page Include: META-->

<link type="text/css" rel="stylesheet" media="all" href="http://content.worldnow.com/global/css/_pub/platform.min.css?ver=7.9.1.1_7.9.1.1">
<link type="text/css" rel="stylesheet" media="all" href="http://KNDU.images.worldnow.com/interface/css/container-e.css?ver=2018-05-21%2013%3A57%3A29_7.9.1.1">
<!--
            [if lt IE 6]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/iequirks.css?ver=7.9.1.1"><![endif]
        -->
<!--
            [if lt IE 7]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie6quirks.css?ver=7.9.1.1"><![endif]
        --><!--
            [if lt IE 10]><link type="text/css" rel="stylesheet" media="screen" href="http://content.worldnow.com/global/css/_pub/quirks/ie9quirks.css?ver=7.9.1.1"><![endif]
        -->
<!--MENU INCLUDES--><style type="text/css">#menu484 UL
                    , #menu484 .wnHorizontal { background-color: #d5d5d5; font-family: Arial; font-size: 11px; font-weight: 700; color: #000000; }
                #menu484 A,
                    #menu484 LI.wnOn .wnSublevel A,
                    #menu484 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 A { font-family: Arial; font-size: 11px; font-weight: 700; color: #000000; }
                #menu484 UL LI.wnOn { background-color: #d5d5d5; color: #000000; }
                    #menu484 LI.wnOn A,
                        #menu484 LI.wnOn .wnSublevel LI.wnOn A,
                        #menu484 LI.wnOn .wnSublevel LI.wnOn .wnLevel3 LI.wnOn A { color: #000000; }
                    #menu484 .wnSublevel { background-color: #d5d5d5;  }
                #menu484 .wnSublevel { border : 1px #d5d5d5 solid; }
                        #menu484 > .wnHorizontal .wnStatic .wnMenuTypeText .wnSublevel { width: 978px; }
                    #menu484 .wnSublevel LI.wnOn { background-color: #d5d5d5;  }
                    #menu484 .wnLeft { background: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_left_off.gif') no-repeat left top; padding-left: 2px; }
                    #menu484 LI.wnOn .wnLeft { background-image: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_left_on.gif'); }
                #menu484 .wnRight { background: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_rt_off.gif') no-repeat right top; padding-right: 3px; }
                    #menu484 LI.wnOn .wnRight { background-image: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_rt_on.gif'); }
                #menu484 .wnRight .wnMiddle { background: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_bg_off.gif') repeat-x; }
                    #menu484 LI.wnOn .wnMiddle { background-image: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_bg_on.gif'); }
                #menu484 .wnHorizontal .wnStatic .wnSublevel LI { background: url('http://KNDU.images.worldnow.com/images/static/gfx/nav_delimiter.gif') no-repeat left center; padding-left: 13px; }
                        #menu484 .wnHorizontal .wnStatic .wnSublevel LI.wnFirstNode { background: none; padding-left: 0; }
                    
</style>

<!--END MENU INCLUDES-->
<script type="text/javascript">
            var wng_pageInfo = {
            affiliateName : 'KNDU',
            affiliateId : '471',
            baseUrl : 'www.nbcrightnow.com',
            includesDomain : 'http://content.worldnow.com',
            includesVersion : '7.9.1.1',
            videoHelpPage : '/global/story.asp?s=1343812&displayHelp=true',
            videoHelpPageMac : '/global/Story.asp?s=2918340&displayHelp=true',
            social : {mdPartnerID : '76',mdPartnerDomain : 'http://dub.kndu.com'},
            registrationId : '556949',
            registrationURL:'registration',
            readableURLenabled: 'True',
            imageDomain : 'http://KNDU.images.worldnow.com'
            };
            
wng_pageInfo.body = {};
wng_pageInfo.taxonomy = {};
wng_pageInfo.build='7.9.1.1';
wng_pageInfo.template='ContainerE-Category';
wng_pageInfo.isPreviewSite=false;
wng_pageInfo.disableSecurityWarning=true;
wng_pageInfo.containerType='C';
wng_pageInfo.ownerAffiliateName='KNDU';
wng_pageInfo.ownerAffiliateId=parseInt('471',10);
wng_pageInfo.containerId=parseInt('314647',10);
wng_pageInfo.containerType='C';
wng_pageInfo.containerClass='category';
wng_pageInfo.contentClassification='News - Special Coverage';
wng_pageInfo.userId=parseInt('',10);
wng_pageInfo.permaLink='/category/314647/hometown-proud-and-fun';
wng_pageInfo.content_authors='';
wng_pageInfo.headline='Hometown Proud and Fun';
wng_pageInfo.pageTitle='Hometown Proud and Fun - NBC Right Now/KNDO/KNDU Tri-Cities, Yakima, WA |';
wng_pageInfo.pageTitleTag='NBC Right Now/KNDO/KNDU Tri-Cities, Yakima, WA |';
wng_pageInfo.pageTitleTagAs='Suffix';
wng_pageInfo.body._id='WNAffKNDU';
wng_pageInfo.body._class='wnContainerType-category wnCenterAlignment';
wng_pageInfo.isMobile=false;
wng_pageInfo.taxonomy.level1='';
wng_pageInfo.taxonomy.level2='';
wng_pageInfo.taxonomy.level3='';
wng_pageInfo.simpleResponsiveBranding=false;
wng_pageInfo.buildInfo = wng_pageInfo.build.match(/[0-9]+/g) || [0,0,'local'];
</script>
<script>
        var wng_pageInfo = window.wng_pageInfo || {};
        wng_pageInfo.ads = {};
        wng_pageInfo.ads["1"]={id:"1",wnsz:"1",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KNDU'},width:468,height:60,wncc:"News - Special Coverage",parent:"WNAd1",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_14 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_16 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_17 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_18 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["20"]={id:"20",wnsz:"20",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KNDU'},width:180,height:150,wncc:"News - Special Coverage",parent:"WNAd20",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_21 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_22 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_23 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_24 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_26 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_27 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_28 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_35 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["41"]={id:"41",wnsz:"41",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KNDU'},width:728,height:90,wncc:"News - Special Coverage",parent:"WNAd41",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_42 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["43"]={id:"43",wnsz:"43",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KNDU'},width:300,height:250,wncc:"News - Special Coverage",parent:"WNAd43",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["44"]={id:"44",wnsz:"44",ownerinfo:{oldformat:1,owner:'nat',split:'100',type:'inline',aff:'KNDU'},width:300,height:75,wncc:"News - Special Coverage",parent:"WNAd44",type:"inline",realvu:"",application:"banner"};
/*Ad wnsz_45 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["46"]={id:"46",wnsz:"46",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KNDU'},width:728,height:90,wncc:"News - Special Coverage",parent:"WNAd46",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["47"]={id:"47",wnsz:"47",ownerinfo:{oldformat:1,owner:'loc',split:'100',type:'dom',aff:'KNDU'},width:300,height:150,wncc:"News - Special Coverage",parent:"WNAd47",type:"dom",realvu:"",application:"banner"};
wng_pageInfo.ads["49"]={id:"49",wnsz:"49",ownerinfo:{oldformat:1,owner:'nat',split:'100',type:'dom',aff:'KNDU'},width:500,height:300,wncc:"News - Special Coverage",parent:"WNAd49",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_50 is disabled (or not defined) at a SITE level.*/
wng_pageInfo.ads["52"]={id:"52",wnsz:"52",ownerinfo:{oldformat:1,owner:'nat',split:'50',type:'dom',aff:'KNDU'},width:300,height:250,wncc:"News - Special Coverage",parent:"WNAd52",type:"dom",realvu:"",application:"banner"};
/*Ad wnsz_54 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_85 is disabled (or not defined) at a SITE level.*/
/*Ad wnsz_86 is disabled (or not defined) at a SITE level.*/
</script>
<script type="text/javascript" src="http://KNDU.images.worldnow.com/interface/js/wnaffiliateconfig.js?ver=2018-05-21%2013%3A57%3A29_7.9.1.1"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/KNDU.config.js?ver=7.9.1.1_7.9.1.1"></script>
<script type="text/javascript" src="http://content.worldnow.com/global/js/_pub/platform.min.js?ver=7.9.1.1_7.9.1.1"></script>
<!--Ad sense not required CURRENT--><script type="text/javascript">
            if(Worldnow.EventMan){Worldnow.EventMan.event('head-javascript-done');}
        </script><!--
                Page Include: HEAD--><!--
                END Page Include: HEAD-->
<!--Customized Page Includes - Head--><link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Montserrat:400,700"><link type="text/css" rel="stylesheet" href="//content.worldnow.com/global/css/customizations/normalize.css?ver=7.9.1.1"><link type="text/css" rel="stylesheet" href="//content.worldnow.com/global/css/customizations/base.css?ver=7.9.1.1"><link type="text/css" rel="stylesheet" href="//content.worldnow.com/global/css/customizations/layouts.css?ver=7.9.1.1"><link type="text/css" rel="stylesheet" href="//ftpcontent.worldnow.com/professionalservices/clients/kndu/custom.css?ver=7.9.1.1"><link type="text/css" rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css"><link type="text/css" rel="stylesheet" href="//cdn.jsdelivr.net/jquery.slick/1.5.6/slick.css"><script src="//ftpcontent.worldnow.com/professionalservices/clients/kndu/custom.js"></script></head><body id="WNAffKNDU" class="wnContainerType-category wnCenterAlignment simple-a category"><!--Google Tag Manager - Analytics Key available for GTM implementation-->
<script>var globalSharedAnalyticsData = { dma: '124', group: 'Cowles' }; (function(){ franklyDataLayer = window.franklyDataLayer || []; var w = window.Worldnow || {}, b = w.Beacon || null; if(b) { franklyDataLayer.push(b.get('page',{ "ua_id":'UA-82494642-58' ,"dma":globalSharedAnalyticsData.dma ,"group":globalSharedAnalyticsData.group})); } }());</script>
<!--Google Tag Manager--><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WV2QLD" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','franklyDataLayer','GTM-WV2QLD');</script><!--End Google Tag Manager-->
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-page',b.get('page')); })(window.Worldnow || {}); (function(w){ var e = w.EventMan || null; if(e) {e.event('bodystart');} })(window.Worldnow || {});</script>
<div id="WNHeaderScripts"></div><div id="WNHeader"><div id="WNAd46" class="wnad wnad46">
<script>wnad_46.load();</script></div>
<!--END wnAdSize-->
<h1>Hometown Proud and Fun - NBC Right Now/KNDO/KNDU Tri-Cities, Yakima, WA |</h1><div class="wnContainerMemberSearch" id="WNContainerMemberSearch-headertop"><div class="wnMemberCenter wnMemberCenter-left wnMemberCenter-loggedOut" id="WNMemberCenter-headertop" refresh="1"><strong>Member Center:</strong><ul><li class="wnMemberOption-accountCreate wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('create')">Create Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logIn wnMemberType-nonuser"><a href="javascript: WNMemberCenterManager.gotoLoginLink('login')">Log In</a><span class="wnSeparator"></span></li><li class="wnMemberOption-accountManage wnMemberType-user"><a href="javascript: WNMemberCenterManager.gotoLoginLink()">Manage Account</a><span class="wnSeparator">|</span></li><li class="wnMemberOption-logOut wnMemberType-user"><a href="javascript:WNMemberCenterManager.gotoLoginLink('logout')">Log Out</a><span class="wnSeparator"></span></li></ul></div>
<!--END wnMemberCenter-->
<div class="wnSearchBox wnSearchBox-right" id="WNSearchBox-headertop"><form method="get" onsubmit="return wnValidateSearchTerm(this,0)" action="/search"><input type="radio" name="vendor" value="ez" id="WNSearchBox-headertop-ez" class="wnVendorChoice" checked><label for="WNSearchBox-headertop-ez">SITE SEARCH</label><input type="radio" name="vendor" value="google_cs" id="WNSearchBox-headertop-google_cs" class="wnVendorChoice"><label for="WNSearchBox-headertop-google_cs">WEB SEARCH BY <img src='http://images.worldnow.com/global/images/google/google_logo.png' alt='Google' class='wnSearchBoxLabelImg-google'></label><input type="text" class="wnQueryText" name="qu" size="20" value=""><input type="submit" class="wnSubmit" value="Go"></form></div><!--END wnSearchBox-->
</div><!--END wnContainerMemberSearch-->
<div id="WNBranding"><img id="WNBrandingImage" usemap="#wnBrandingMap" alt="" border="0" src="http://KNDU.images.worldnow.com/images/static/hdr/hdr_branding.jpg"><map name="wnBrandingMap"><area shape="rect" coords="0,0,980,1000" target="_top" href="/"></map><img id="WNPrintBrandingImage" style="display:none;" border="0" width="607" height="37" src="http://KNDU.images.worldnow.com/images/static/hdr/hdr_607x37.gif"></div><!--END WNBranding--></div><!--END WNHeader--><section class="main wn-bg-page-main"><div id="WNColsAll" class="columnsall wnColConfig"><div class=""><section class="nav wn-bg-page-nav"><nav class="simple-b main"><ul class="sf-menu sf-arrows sf-horizontal"><li class=""><a class="sf-with-ul" href="/" target="">Home</a><ul><li class=""><a class="" href="/story/10980855/news-links-on-kndo-and-kndu-tv" target="">News Links </a></li><li class=""><a class="" href="/story/4706062/wake-up-northwest-birthdays" target="">Birthdays</a></li><li class=""><a class="" href="/link/318471/contact-us" target="">Contact Us</a></li><li class=""><a class="" href="/category/246115/how-to-get-swx" target="">How to Get SWX</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/76089/news" target="">News</a><ul><li class=""><a class="" href="/category/78468/wake-up-northwest" target="">Wake Up Northwest </a></li><li class=""><a class="" href="/category/78263/tri-cities-news" target="">Tri-Cities News</a></li><li class=""><a class="" href="/category/226109/yakima-news" target="">Yakima News Today</a></li><li class=""><a class="" href="/category/242801/national-news" target="">NW/National News</a></li><li class=""><a class="" href="/category/297908/dialed-in" target="">Dialed In</a></li><li class=""><a class="" href="/category/82513/crime-stoppers" target="">Crime Stoppers</a></li><li class=""><a class="" href="/category/324126/glenns-hometown-news" target="">Glenn's Hometown News</a></li><li class=""><a class="" href="/category/87943/health-alert" target="">Astria Health - Health Alert</a></li></ul></li><li class=""><a class="sf-with-ul" href="/weather" target="">Weather</a><ul><li class=""><a class="" href="/link/294758/current-conditions-on-snoqualmie-pass" target="_blank">Current Conditions on Snoqualmie Pass</a></li><li class=""><a class="" href="/category/329191/weather-center" target="">Blue Dog RV Weather Network </a></li><li class=""><a class="" href="/link/609592/interactive-radar" target="">Interactive Radar</a></li><li class=""><a class="" href="/link/437248/share-your-weather-photos" target="">Weather Pictures</a></li><li class=""><a class="" href="/category/319004/montys-blog" target="">Monty's Blog</a></li><li class=""><a class="" href="/category/91012/washington-webcams" target="">Washington Webcams</a></li><li class=""><a class="" href="/category/78271/ski-reports" target="">Ski Reports</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/189473/video-center" target="">Video Center</a><ul><li class=""><a class="" href="/category/267555/kndu-programming" target="">KNDU Programming</a></li><li class=""><a class="" href="/category/267556/kndo-programming" target="">KNDO Programming</a></li><li class=""><a class="" href="/category/247803/nbc-right-now-live-streaming-newscasts" target="">NBC Right Now Live Streaming Newscasts</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/327188/sports" target="">Sports </a><ul><li class=""><a class="" href="/category/76090/sports" target="">Local Sports</a></li><li class=""><a class="" href="/link/381984/swx-sports" target="">SWX Sports</a></li><li class=""><a class="" href="/link/779800/lynx-healthcare-athlete-of-the-month" target="">Lynx Healthcare Athlete of the Month</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/76091/community" target="">Community</a><ul><li class="active"><a class="active " href="/category/314647/hometown-proud-and-fun" target="">Hometown Proud and Fun</a></li><li class=""><a class="" href="/category/329807/tell-me-something-good" target="">Tell Me Something Good!</a></li><li class=""><a class="" href="/category/98644/nbc-right-now-best-and-brightest" target="">NBC Right Now Best and Brightest</a></li><li class=""><a class="" href="/category/316121/heartwarming-happenings" target="">Heartwarming Happenings</a></li><li class=""><a class="" href="/category/246426/kndu-classroom-makeover" target="">KNDU Classroom Makeover</a></li><li class=""><a class="" href="/story/26048450/kndokndu-public-file" target="">KNDO/KNDU Public Files</a></li><li class=""><a class="" href="/link/580625/events-calendar-link-community-tab" target="">Events</a></li><li class=""><a class="" href="/category/323489/wake-up-your-garden" target="">Wake Up Your Garden</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/259182/check-it-out" target="">Check It Out</a><ul><li class=""><a class="" href="/category/246426/kndu-classroom-makeover" target="">KNDU Classroom Makeover</a></li><li class=""><a class="" href="/category/324885/glenn-on-the-green" target="">Glenn on the Green</a></li><li class=""><a class="" href="/category/327977/so-you-want-to-buy-a-house" target="">So You Want to Buy a House </a></li><li class=""><a class="" href="/category/298892/wake-up-your-real-estate" target="">Wake Up Your Real Estate</a></li><li class=""><a class="" href="/category/331078/millennials-on-the-move" target="">Millennials on the Move</a></li><li class=""><a class="" href="/category/102890/contests" target="">Contests</a></li><li class=""><a class="" href="/link/646191/check-it-out-pictures" target="">Check It Out: Pictures</a></li></ul></li><li class=""><a class="sf-with-ul" href="/category/78221/contact-us" target="">Contact Us</a><ul><li class=""><a class="" href="/story/30801782/on-air-contest-rules" target="">ON-Air Contest Rules</a></li><li class=""><a class="" href="/link/437248/share-your-weather-photos" target="">Weather Pictures</a></li><li class=""><a class="" href="/story/8936765/purchase-a-copy-of-our-newscast" target="">News DVD Copies</a></li><li class=""><a class="" href="/category/242962/nbc-right-now-news-team-bios" target="">The NBC Right Now Team</a></li><li class=""><a class="" href="/story/4706062/wake-up-northwest-birthdays" target="">Birthdays</a></li><li class=""><a class="" href="/story/26048450/kndokndu-public-file" target="">KNDO/KNDU Public Files</a></li><li class=""><a class="" href="/category/101558/jobs-at-kndo-and-kndu" target="">Employment </a></li></ul></li></ul></nav></section></div><div id="WNCols234-5" class="columns wnColConfig"><div class="debug hide" data-debug="Display Size 23 attempting to load..."></div><div class="debug hide" data-debug="Display Size 40 attempting to load..."></div><div id="WNCols23-4" class="wnColConfig4"><div class="debug hide" data-debug="Display Size 33 attempting to load..."></div><div id="WNCol23" class="wnColConfig2 columns col2 col3"><div id="WNCol23Top"><div class="debug hide" data-debug="Display Size 29 attempting to load..."></div><!--DISPLAY SIZE 29: Feature - Col 2/3A-->
<div id="WNDS29" class="wnDS29 wnDSContainer-feature wnDS">
<div class="wnDSItems-feature">
<script>Worldnow.Helpers.debug('UB Hometown Proud Graphic (545466)', 'UB_545466');</script><div class="wnDVUtilityBlock"><!DOCTYPE html>
<html>
<head>
<style>
table {
    border-collapse: collapse;
    border-spacing: 0;
    width: 100%;
    border: 0px solid #ddd;
}
th {
    border: none;
    text-align: left;
    padding: 4px;
    width: 200px;
}
td {
    border: none;
    text-align: left;
    padding: 4px;
}
tr:nth-child(even){background-color: #ffffff}
</style>
</head>
<body>
<img src="http://KNDU.images.worldnow.com/images/16619708_G.jpg" width="100%">
<center><h2> </h2>
<p></p></center> 
</div><script>Worldnow.Helpers.debug('UB Hometown Proud Graphic (545466)', 'UB_545466');</script></div><!--END wnDSItems-->
</div><!--
                END wnDS29-->
<div id="WNAd1" class="wnad wnad1">
<script>wnad_1.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 21 attempting to load..."></div><div class="wnClear"></div></div><!--END WNCol23Top--><div id="WNCol2" class="column col2"><div class="debug hide" data-debug="Display Size 16 attempting to load..."></div><div class="debug hide" data-debug="Display Size 8 attempting to load..."></div><div class="debug hide" data-debug="Display Size 45 attempting to load..."></div><!--Start of Display Size: Half Horizontal - Col 2 (-4)--><div class="wnBlock displaySize displaySizeId-4" id="DisplaySizeId-4"><ul class="wnGroup contentGroup odd last"><li class="wnItem header"><h3><span class="text abridgedHeadline">Hometown Proud and Fun</span><a class="wnContent more" href="/category/314647/hometown-proud-and-fun"><span class="text">More&gt;&gt;</span></a><div class="wnClear"></div></h3></li><li class="wnItem feature Station23 story priority-1 odd odd-4"><meta content="Station 23"><meta content="2017-08-26 00:11:02"><h4 class="wnContent headline"><a href="/story/36221194/hometown-proud-yakimas-classic-the-stop-and-go-drive-in"><span class="text">Hometown Proud: Yakima's classic, the Stop And Go Drive-In</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/36221194/hometown-proud-yakimas-classic-the-stop-and-go-drive-in"><span class="text">Hometown Proud: Yakima's classic, the Stop And Go Drive-In</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, August 25 2017 8:40 PM EDT</span><span class="wnContent timestamp gmttime">2017-08-26 00:40:29 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/36221194/hometown-proud-yakimas-classic-the-stop-and-go-drive-in"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14753440_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36221194/hometown-proud-yakimas-classic-the-stop-and-go-drive-in"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14753440_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Veronica Padilla checked out a drive-in that has been growing along with the community.&nbsp;</p></span><a class="more" href="/story/36221194/hometown-proud-yakimas-classic-the-stop-and-go-drive-in"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Veronica Padilla checked out a drive-in that has been growing along with the community.&nbsp;</p></span><a class="more" href="/story/36221194/hometown-proud-yakimas-classic-the-stop-and-go-drive-in"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-2 even even-4"><meta content="Station 23"><meta content="2017-08-25 23:48:50"><h4 class="wnContent headline"><a href="/story/36221123/hometown-proud-tieton-cider-works-in-yakima"><span class="text">Hometown Proud: Tieton Cider Works in Yakima</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36221123/hometown-proud-tieton-cider-works-in-yakima"><span class="text">Hometown Proud: Tieton Cider Works in Yakima</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, August 25 2017 7:48 PM EDT</span><span class="wnContent timestamp gmttime">2017-08-25 23:48:50 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/36221123/hometown-proud-tieton-cider-works-in-yakima"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14753039_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36221123/hometown-proud-tieton-cider-works-in-yakima"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14753039_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Gilbert Magallon visited a brewery in Yakima that specializes in cider.&nbsp;</p> </span><a class="more" href="/story/36221123/hometown-proud-tieton-cider-works-in-yakima"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Gilbert Magallon visited a brewery in Yakima that specializes in cider.&nbsp;</p></span><a class="more" href="/story/36221123/hometown-proud-tieton-cider-works-in-yakima"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-3 odd odd-4"><meta content="Station 25"><meta content="2017-08-11 21:14:17"><h4 class="wnContent headline"><a href="/story/36118553/hometown-proud-pendleton-underground-tours"><span class="text">Hometown Proud: Pendleton Underground Tours</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/36118553/hometown-proud-pendleton-underground-tours"><span class="text">Hometown Proud: Pendleton Underground Tours</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, August 11 2017 5:14 PM EDT</span><span class="wnContent timestamp gmttime">2017-08-11 21:14:17 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/36118553/hometown-proud-pendleton-underground-tours"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14634909_G.jpg?auto=webp&amp;disable=upscale&amp;width=650" title="Photo courtesy of Pendleton Underground Tours" alt="Photo courtesy of Pendleton Underground Tours"></a><span class="caption left width90"><span class="text">Photo courtesy of Pendleton Underground Tours</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/36118553/hometown-proud-pendleton-underground-tours"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14634909_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>The City of Pendleton has a bit of a concealed history. &nbsp;</p> </span><a class="more" href="/story/36118553/hometown-proud-pendleton-underground-tours"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The City of Pendleton has a bit of a concealed history. &nbsp;</p></span><a class="more" href="/story/36118553/hometown-proud-pendleton-underground-tours"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-4 even even-4"><meta content="Station 25"><meta content="2017-07-15 01:29:22"><h4 class="wnContent headline"><a href="/story/35890948/hometown-proud-the-history-of-the-tri-city-country-club"><span class="text">Hometown Proud: The history of the Tri-City Country Club</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35890948/hometown-proud-the-history-of-the-tri-city-country-club"><span class="text">Hometown Proud: The history of the Tri-City Country Club</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 14 2017 9:39 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-15 01:39:32 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35890948/hometown-proud-the-history-of-the-tri-city-country-club"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14390726_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35890948/hometown-proud-the-history-of-the-tri-city-country-club"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14390726_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's segment of Hometown Proud: What Grows Here, reporter Kristina Shalhoup checked out the history of the Tri-City Country Club.&nbsp;</p></span><a class="more" href="/story/35890948/hometown-proud-the-history-of-the-tri-city-country-club"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's segment of Hometown Proud: What Grows Here, reporter Kristina Shalhoup checked out the history of the Tri-City Country Club.&nbsp;</p></span><a class="more" href="/story/35890948/hometown-proud-the-history-of-the-tri-city-country-club"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-5 odd odd-4"><meta content="Station 25"><meta content="2017-07-15 00:33:07"><h4 class="wnContent headline"><a href="/story/35890777/hometown-proud-the-history-of-our-own-kennewick-station"><span class="text">Hometown Proud: The history of our own Kennewick station</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35890777/hometown-proud-the-history-of-our-own-kennewick-station"><span class="text">Hometown Proud: The history of our own Kennewick station</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 14 2017 8:44 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-15 00:44:54 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35890777/hometown-proud-the-history-of-our-own-kennewick-station"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14390436_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35890777/hometown-proud-the-history-of-our-own-kennewick-station"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14390436_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For Kennewick's&nbsp;segment of Hometown Proud - and at the request of some of our viewers - we looked into the history of our station at 3312 W. Kennewick Avenue.&nbsp;</p></span><a class="more" href="/story/35890777/hometown-proud-the-history-of-our-own-kennewick-station"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For Kennewick's&nbsp;segment of Hometown Proud - and at the request of some of our viewers - we looked into the history of our station at 3312 W. Kennewick Avenue.&nbsp;</p></span><a class="more" href="/story/35890777/hometown-proud-the-history-of-our-own-kennewick-station"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-6 even even-4"><meta content="Station 25"><meta content="2017-07-08 01:32:33"><h4 class="wnContent headline"><a href="/story/35837484/hometown-proud-sweets-to-eat-at-tsp-bakeshop"><span class="text">Hometown Proud: Sweets to eat at Tsp Bakeshop</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837484/hometown-proud-sweets-to-eat-at-tsp-bakeshop"><span class="text">Hometown Proud: Sweets to eat at Tsp Bakeshop</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 9:37 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-08 01:37:40 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35837484/hometown-proud-sweets-to-eat-at-tsp-bakeshop"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14331140_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35837484/hometown-proud-sweets-to-eat-at-tsp-bakeshop"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14331140_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud, reporter Jaclyn Selesky checked out a sweet shop in West Richland.&nbsp;</p></span><a class="more" href="/story/35837484/hometown-proud-sweets-to-eat-at-tsp-bakeshop"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud, reporter Jaclyn Selesky checked out a sweet shop in West Richland.&nbsp;</p></span><a class="more" href="/story/35837484/hometown-proud-sweets-to-eat-at-tsp-bakeshop"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-7 odd odd-4"><meta content="Station 25"><meta content="2017-07-08 01:25:03"><h4 class="wnContent headline"><a href="/story/35837452/new-steam-middle-school-in-west-richland-nearing-completion"><span class="text">New STEAM middle school in West Richland nearing completion</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837452/new-steam-middle-school-in-west-richland-nearing-completion"><span class="text">New STEAM middle school in West Richland nearing completion</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 9:35 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-08 01:35:40 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35837452/new-steam-middle-school-in-west-richland-nearing-completion"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14331126_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35837452/new-steam-middle-school-in-west-richland-nearing-completion"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14331126_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud, reporter Jaclyn Selesky decided to check out the progress of Leona Libby Middle School in West Richland.&nbsp;</p></span><a class="more" href="/story/35837452/new-steam-middle-school-in-west-richland-nearing-completion"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud, reporter Jaclyn Selesky decided to check out the progress of Leona Libby Middle School in West Richland.&nbsp;</p></span><a class="more" href="/story/35837452/new-steam-middle-school-in-west-richland-nearing-completion"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-8 even even-4"><meta content="Station 25"><meta content="2017-07-08 00:40:42"><h4 class="wnContent headline"><a href="/story/35837344/hometown-proud-a-unique-distillery-called-black-heron-spirits"><span class="text">Hometown Proud: A unique distillery called Black Heron Spirits</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35837344/hometown-proud-a-unique-distillery-called-black-heron-spirits"><span class="text">Hometown Proud: A unique distillery called Black Heron Spirits</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 7 2017 8:48 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-08 00:48:26 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35837344/hometown-proud-a-unique-distillery-called-black-heron-spirits"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14330856_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35837344/hometown-proud-a-unique-distillery-called-black-heron-spirits"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14330856_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud, we went just a hop, skip, and a jump away to West Richland.&nbsp;</p></span><a class="more" href="/story/35837344/hometown-proud-a-unique-distillery-called-black-heron-spirits"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud, we went just a hop, skip, and a jump away to West Richland.&nbsp;</p></span><a class="more" href="/story/35837344/hometown-proud-a-unique-distillery-called-black-heron-spirits"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-9 odd odd-4"><meta content="Station 25"><meta content="2017-06-30 23:51:34"><h4 class="wnContent headline"><a href="/story/35792703/hometown-proud-turkeys-and-wine-in-benton-city"><span class="text">Hometown Proud: Turkeys and wine in Benton City</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35792703/hometown-proud-turkeys-and-wine-in-benton-city"><span class="text">Hometown Proud: Turkeys and wine in Benton City</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, June 30 2017 9:37 PM EDT</span><span class="wnContent timestamp gmttime">2017-07-01 01:37:24 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35792703/hometown-proud-turkeys-and-wine-in-benton-city"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14279383_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35792703/hometown-proud-turkeys-and-wine-in-benton-city"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14279383_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>This week for Hometown Proud, Kristina Shalhoup spent some time learning about everything that grows on a local and incredibly self-sufficient farm.&nbsp;</p></span><a class="more" href="/story/35792703/hometown-proud-turkeys-and-wine-in-benton-city"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>This week for Hometown Proud, Kristina Shalhoup spent some time learning about everything that grows on a local and incredibly self-sufficient farm.&nbsp;</p></span><a class="more" href="/story/35792703/hometown-proud-turkeys-and-wine-in-benton-city"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-10 even even-4"><meta content="Station 23"><meta content="2017-06-24 01:02:52"><h4 class="wnContent headline"><a href="/story/35739469/hometown-proud-job-growth-in-toppenish-thanks-to-legends-casino"><span class="text">Hometown Proud: Job growth in Toppenish, thanks to Legends Casino</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35739469/hometown-proud-job-growth-in-toppenish-thanks-to-legends-casino"><span class="text">Hometown Proud: Job growth in Toppenish, thanks to Legends Casino</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, June 23 2017 9:37 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-24 01:37:57 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35739469/hometown-proud-job-growth-in-toppenish-thanks-to-legends-casino"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14221294_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35739469/hometown-proud-job-growth-in-toppenish-thanks-to-legends-casino"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14221294_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Gilbert Magallon headed to Toppenish, where he checked out how Legends Casino is experiencing growth.&nbsp;</p></span><a class="more" href="/story/35739469/hometown-proud-job-growth-in-toppenish-thanks-to-legends-casino"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Gilbert Magallon headed to Toppenish, where he checked out how Legends Casino is experiencing growth.&nbsp;</p></span><a class="more" href="/story/35739469/hometown-proud-job-growth-in-toppenish-thanks-to-legends-casino"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-11 odd odd-4"><meta content="Station 23"><meta content="2017-06-24 00:21:40"><h4 class="wnContent headline"><a href="/story/35739312/hometown-proud-generations-of-hops-farmers-in-toppenish"><span class="text">Hometown Proud:  Generations of hops farmers in Toppenish</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35739312/hometown-proud-generations-of-hops-farmers-in-toppenish"><span class="text">Hometown Proud:  Generations of hops farmers in Toppenish</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, June 23 2017 8:39 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-24 00:39:15 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35739312/hometown-proud-generations-of-hops-farmers-in-toppenish"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14220917_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35739312/hometown-proud-generations-of-hops-farmers-in-toppenish"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14220917_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Gilbert Magallon went to Toppenish and checked out Brulotte Farms, where they told him about their hops.&nbsp;</p></span><a class="more" href="/story/35739312/hometown-proud-generations-of-hops-farmers-in-toppenish"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud: What Grows Here, reporter Gilbert Magallon went to Toppenish and checked out Brulotte Farms, where they told him about their hops.&nbsp;</p></span><a class="more" href="/story/35739312/hometown-proud-generations-of-hops-farmers-in-toppenish"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-12 even even-4"><meta content="Station 25"><meta content="2017-06-17 00:47:17"><h4 class="wnContent headline"><a href="/story/35685653/hometown-proud-the-frazier-farmstead-museum-in-milton-freewater"><span class="text">Hometown Proud: The Frazier Farmstead Museum in Milton-Freewater</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35685653/hometown-proud-the-frazier-farmstead-museum-in-milton-freewater"><span class="text">Hometown Proud: The Frazier Farmstead Museum in Milton-Freewater</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, June 19 2017 1:18 PM EDT</span><span class="wnContent timestamp gmttime">2017-06-19 17:18:46 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35685653/hometown-proud-the-frazier-farmstead-museum-in-milton-freewater"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/14162504_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35685653/hometown-proud-the-frazier-farmstead-museum-in-milton-freewater"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/14162504_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud, reporter Kristina Shalhoup went down to Milton-Freewater to learn about some of the history behind the area.&nbsp;</p></span><a class="more" href="/story/35685653/hometown-proud-the-frazier-farmstead-museum-in-milton-freewater"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud, reporter Kristina Shalhoup went down to Milton-Freewater to learn about some of the history behind the area.&nbsp;</p></span><a class="more" href="/story/35685653/hometown-proud-the-frazier-farmstead-museum-in-milton-freewater"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-13 odd odd-4"><meta content="Station 25"><meta content="2017-05-29 11:49:50"><h4 class="wnContent headline"><a href="/story/35538049/hometown-proud-pineapple-petes-shaved-ice"><span class="text">Hometown Proud: Pineapple Pete's Shaved Ice</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35538049/hometown-proud-pineapple-petes-shaved-ice"><span class="text">Hometown Proud: Pineapple Pete's Shaved Ice</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, May 29 2017 7:49 AM EDT</span><span class="wnContent timestamp gmttime">2017-05-29 11:49:49 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summary abridged"><span class="text">WALLA WALLA, WA- Pineapple Pete's Shaved Ice started in College Place out of a shed and they've since outgrown that shed and moved into a storefront.&nbsp;  One of the owners told us the shed was, &quot;10 by 13 and it was for two summers we were operating from that&quot; says Slvic Tkachev. Five years ago Tkachev and his co-owner Marc Hernandez were co-workers facing cutbacks at work and that's what sparked this leap of faith.&nbsp;  &quot;I&nbsp;had shaved ice machine and he had mon...</span><a class="more" href="/story/35538049/hometown-proud-pineapple-petes-shaved-ice"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">WALLA WALLA, WA- Pineapple Pete's Shaved Ice started in College Place out of a shed and they've since outgrown that shed and moved into a storefront.&nbsp;  One of the owners told us the shed was, &quot;10 by 13 and it was for two summers we were operating from that&quot; says Slvic Tkachev. Five years ago Tkachev and his co-owner Marc Hernandez were co-workers facing cutbacks at work and that's what sparked this leap of faith.&nbsp;  &quot;I&nbsp;had shaved ice machine and he had mon...</span><a class="more" href="/story/35538049/hometown-proud-pineapple-petes-shaved-ice"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-14 even even-4"><meta content="Station 25"><meta content="2017-05-26 23:55:33"><h4 class="wnContent headline"><a href="/story/35529680/hometown-proud-plowing-crops-by-horse-in-college-place"><span class="text">Hometown Proud: Plowing crops by horse in College Place</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/35529680/hometown-proud-plowing-crops-by-horse-in-college-place"><span class="text">Hometown Proud: Plowing crops by horse in College Place</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 26 2017 8:59 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-27 00:59:14 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35529680/hometown-proud-plowing-crops-by-horse-in-college-place"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/13994091_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35529680/hometown-proud-plowing-crops-by-horse-in-college-place"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/13994091_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For three years, Hayshaker Farm has been doing things a little differently.&nbsp;</p> </span><a class="more" href="/story/35529680/hometown-proud-plowing-crops-by-horse-in-college-place"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For three years, Hayshaker Farm has been doing things a little differently.&nbsp;</p></span><a class="more" href="/story/35529680/hometown-proud-plowing-crops-by-horse-in-college-place"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-15 odd odd-4"><meta content="Station 25"><meta content="2017-05-13 01:47:45"><h4 class="wnContent headline"><a href="/story/35419562/lexington-veterinarian"><span class="text">Hometown Proud: Lexington veterinarian helping livestock</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35419562/lexington-veterinarian"><span class="text">Hometown Proud: Lexington veterinarian helping livestock</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 26 2017 7:57 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-26 23:57:19 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35419562/lexington-veterinarian"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/13870593_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35419562/lexington-veterinarian"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/13870593_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>LEXINGTON, OR.-- Dick Temple has been a veterinarian for decades, and he's spent three of them in Lexington. Since the area is so filled with livestock, his usual patients can weigh a few-hundred pounds.&nbsp;</p></span><a class="more" href="/story/35419562/lexington-veterinarian"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>LEXINGTON, OR.-- Dick Temple has been a veterinarian for decades, and he's spent three of them in Lexington. Since the area is so filled with livestock, his usual patients can weigh a few-hundred pounds.&nbsp;</p></span><a class="more" href="/story/35419562/lexington-veterinarian"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-16 even even-4"><meta content="Station 25"><meta content="2017-05-13 01:27:45"><h4 class="wnContent headline"><a href="/story/35419500/hometown-proud-grain-cattle-growing-agriculture-industry"><span class="text">Hometown Proud: Grain & cattle growing agriculture industry</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35419500/hometown-proud-grain-cattle-growing-agriculture-industry"><span class="text">Hometown Proud: Grain & cattle growing agriculture industry</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 26 2017 7:57 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-26 23:57:05 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35419500/hometown-proud-grain-cattle-growing-agriculture-industry"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/13870578_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35419500/hometown-proud-grain-cattle-growing-agriculture-industry"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/13870578_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>LEXINGTON, OR.-- If you're driving through the farms and fields surrounding Lexington, you've probably realized that you're in a kingdom of agriculture... and if that's the case, then the Thompsons could be considered the royal family. &nbsp;</p></span><a class="more" href="/story/35419500/hometown-proud-grain-cattle-growing-agriculture-industry"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>LEXINGTON, OR.-- If you're driving through the farms and fields surrounding Lexington, you've probably realized that you're in a kingdom of agriculture... and if that's the case, then the Thompsons could be considered the royal family. &nbsp;</p></span><a class="more" href="/story/35419500/hometown-proud-grain-cattle-growing-agriculture-industry"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-17 odd odd-4"><meta content="Station 25"><meta content="2017-05-20 01:23:09"><h4 class="wnContent headline"><a href="/story/35475320/hometown-proud-a-gardening-club-unlike-any-other-in-umatilla"><span class="text">Hometown Proud: A gardening club unlike any other in Umatilla</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35475320/hometown-proud-a-gardening-club-unlike-any-other-in-umatilla"><span class="text">Hometown Proud: A gardening club unlike any other in Umatilla</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 19 2017 9:36 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-20 01:36:01 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35475320/hometown-proud-a-gardening-club-unlike-any-other-in-umatilla"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/13933581_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35475320/hometown-proud-a-gardening-club-unlike-any-other-in-umatilla"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/13933581_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's Hometown Proud, reporter Rex Carlin learned that one Umatilla club has been keeping the city looking good since the 1930s.&nbsp;</p></span><a class="more" href="/story/35475320/hometown-proud-a-gardening-club-unlike-any-other-in-umatilla"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's Hometown Proud, reporter Rex Carlin learned that one Umatilla club has been keeping the city looking good since the 1930s.&nbsp;</p></span><a class="more" href="/story/35475320/hometown-proud-a-gardening-club-unlike-any-other-in-umatilla"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-18 even even-4"><meta content="Station 25"><meta content="2017-05-19 23:57:55"><h4 class="wnContent headline"><a href="/story/35474992/hometown-proud-some-unique-oregon-history-in-the-town-of-umatilla"><span class="text">Hometown Proud: Some unique Oregon history in the town of Umatilla</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35474992/hometown-proud-some-unique-oregon-history-in-the-town-of-umatilla"><span class="text">Hometown Proud: Some unique Oregon history in the town of Umatilla</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 19 2017 8:39 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-20 00:39:47 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35474992/hometown-proud-some-unique-oregon-history-in-the-town-of-umatilla"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/13933181_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35474992/hometown-proud-some-unique-oregon-history-in-the-town-of-umatilla"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/13933181_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For this week's segment of Hometown Proud, we got a one-stop-shop history lesson for Umatilla's past.</p> </span><a class="more" href="/story/35474992/hometown-proud-some-unique-oregon-history-in-the-town-of-umatilla"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For this week's segment of Hometown Proud, we got a one-stop-shop history lesson for Umatilla's past.</p></span><a class="more" href="/story/35474992/hometown-proud-some-unique-oregon-history-in-the-town-of-umatilla"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-19 odd odd-4"><meta content="Station 25"><meta content="2017-05-06 00:19:52"><h4 class="wnContent headline"><a href="/story/35357451/hometown-proud-a-one-stop-shop-for-prescriptions-and-pop-in-hermiston"><span class="text">Hometown Proud: A one-stop-shop for prescriptions and pop in Hermiston</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/35357451/hometown-proud-a-one-stop-shop-for-prescriptions-and-pop-in-hermiston"><span class="text">Hometown Proud: A one-stop-shop for prescriptions and pop in Hermiston</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 5 2017 8:45 PM EDT</span><span class="wnContent timestamp gmttime">2017-05-06 00:45:16 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/35357451/hometown-proud-a-one-stop-shop-for-prescriptions-and-pop-in-hermiston"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/13805936_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/35357451/hometown-proud-a-one-stop-shop-for-prescriptions-and-pop-in-hermiston"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/13805936_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>For our first Hometown Proud story of this year, we visited Hermiston to find out what makes the people there proud of their hometown.&nbsp;</p></span><a class="more" href="/story/35357451/hometown-proud-a-one-stop-shop-for-prescriptions-and-pop-in-hermiston"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>For our first Hometown Proud story of this year, we visited Hermiston to find out what makes the people there proud of their hometown.&nbsp;</p></span><a class="more" href="/story/35357451/hometown-proud-a-one-stop-shop-for-prescriptions-and-pop-in-hermiston"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-20 even even-4"><meta content="Station 23"><meta content="2016-08-12 23:01:47"><h4 class="wnContent headline"><a href="/story/32749579/hometown-proud-catching-a-bite-at-the-cougar-den-in-white-swan"><span class="text">HOMETOWN PROUD: Catching a bite at the Cougar Den in White Swan</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/32749579/hometown-proud-catching-a-bite-at-the-cougar-den-in-white-swan"><span class="text">HOMETOWN PROUD: Catching a bite at the Cougar Den in White Swan</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Tuesday, August 16 2016 4:57 PM EDT</span><span class="wnContent timestamp gmttime">2016-08-16 20:57:35 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/32749579/hometown-proud-catching-a-bite-at-the-cougar-den-in-white-swan"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/11323366_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/32749579/hometown-proud-catching-a-bite-at-the-cougar-den-in-white-swan"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/11323366_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>The Cougar Den is home to the only restaurant in White Swan, but that's not all they have to offer.&nbsp;</p> </span><a class="more" href="/story/32749579/hometown-proud-catching-a-bite-at-the-cougar-den-in-white-swan"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>The Cougar Den is home to the only restaurant in White Swan, but that's not all they have to offer.&nbsp;</p></span><a class="more" href="/story/32749579/hometown-proud-catching-a-bite-at-the-cougar-den-in-white-swan"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-21 odd odd-4"><meta content="Station 25"><meta content="2016-08-09 01:22:30"><h4 class="wnContent headline"><a href="/story/32713494/hometown-proud-free-history-lessons-await-at-the-franklin-county-museum-in-pasco"><span class="text">HOMETOWN PROUD: Free history lessons await at the Franklin County Museum in Pasco</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/32713494/hometown-proud-free-history-lessons-await-at-the-franklin-county-museum-in-pasco"><span class="text">HOMETOWN PROUD: Free history lessons await at the Franklin County Museum in Pasco</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, August 8 2016 9:22 PM EDT</span><span class="wnContent timestamp gmttime">2016-08-09 01:22:30 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summary abridged"><span class="text"><p>Today was one of the first times our reporter Haley Gibbs really got the chance to explore Pasco, and because she wanted to know everything there is to know, she visited the Franklin County Museum to get the story.&nbsp;</p> </span><a class="more" href="/story/32713494/hometown-proud-free-history-lessons-await-at-the-franklin-county-museum-in-pasco"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Today was one of the first times our reporter Haley Gibbs really got the chance to explore Pasco, and because she wanted to know everything there is to know, she visited the Franklin County Museum to get the story.&nbsp;</p></span><a class="more" href="/story/32713494/hometown-proud-free-history-lessons-await-at-the-franklin-county-museum-in-pasco"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-22 even even-4"><meta content="Station 25"><meta content="2016-08-09 01:10:09"><h4 class="wnContent headline"><a href="/story/32713443/hometown-proud-vieras-bakery-in-pasco"><span class="text">HOMETOWN PROUD: Viera's Bakery in Pasco</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/32713443/hometown-proud-vieras-bakery-in-pasco"><span class="text">HOMETOWN PROUD: Viera's Bakery in Pasco</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Monday, August 8 2016 9:10 PM EDT</span><span class="wnContent timestamp gmttime">2016-08-09 01:10:09 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summary abridged"><span class="text"><p>All you have to do is walk into Viera's Bakery, and you'll know everything is baked fresh.</p> </span><a class="more" href="/story/32713443/hometown-proud-vieras-bakery-in-pasco"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>All you have to do is walk into Viera's Bakery, and you'll know everything is baked fresh.</p></span><a class="more" href="/story/32713443/hometown-proud-vieras-bakery-in-pasco"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-23 odd odd-4"><meta content="Station 23"><meta content="2016-07-16 02:27:40"><h4 class="wnContent headline"><a href="/story/32458907/at-the-trading-post-in-naches-for-hometown-proud"><span class="text">HOMETOWN PROUD: At the Trading Post and the Little Red School House in Naches</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/32458907/at-the-trading-post-in-naches-for-hometown-proud"><span class="text">HOMETOWN PROUD: At the Trading Post and the Little Red School House in Naches</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, July 22 2016 2:18 PM EDT</span><span class="wnContent timestamp gmttime">2016-07-22 18:18:11 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/32458907/at-the-trading-post-in-naches-for-hometown-proud"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10997798_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/32458907/at-the-trading-post-in-naches-for-hometown-proud"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10997798_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>NACHES, WA - This week's Hometown Proud took our reporters to Naches, where they visited the well-known Trading Post. It's right off the highway and sells fruits, vegetables, and much more.&nbsp; But there's another place to buy your produce, and it's known as the Little Red School House, which isn't a school, nor is it a house!&nbsp;</p> </span><a class="more" href="/story/32458907/at-the-trading-post-in-naches-for-hometown-proud"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>NACHES, WA - This week's Hometown Proud took our reporters to Naches, where they visited the well-known Trading Post. It's right off the highway and sells fruits, vegetables, and much more.&nbsp; But there's another place to buy your produce, and it's known as the Little Red School House, which isn't a school, nor is it a house!&nbsp;</p></span><a class="more" href="/story/32458907/at-the-trading-post-in-naches-for-hometown-proud"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-24 even even-4"><meta content="Station 25"><meta content="2016-06-11 02:06:08"><h4 class="wnContent headline"><a href="/story/32197565/hometown-proud-a-finley-apricot-farm-has-over-300-fruit-trees"><span class="text">HOMETOWN PROUD: A Finley apricot farm has over 300 fruit trees</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/32197565/hometown-proud-a-finley-apricot-farm-has-over-300-fruit-trees"><span class="text">HOMETOWN PROUD: A Finley apricot farm has over 300 fruit trees</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, June 10 2016 10:06 PM EDT</span><span class="wnContent timestamp gmttime">2016-06-11 02:06:09 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/32197565/hometown-proud-a-finley-apricot-farm-has-over-300-fruit-trees"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10755290_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/32197565/hometown-proud-a-finley-apricot-farm-has-over-300-fruit-trees"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10755290_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>This week's hometown proud brought us to Finley. When driving through town we stumbled upon an apricot farm.</p> </span><a class="more" href="/story/32197565/hometown-proud-a-finley-apricot-farm-has-over-300-fruit-trees"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>This week's hometown proud brought us to Finley. When driving through town we stumbled upon an apricot farm.</p></span><a class="more" href="/story/32197565/hometown-proud-a-finley-apricot-farm-has-over-300-fruit-trees"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-25 odd odd-4"><meta content="Station 23"><meta content="2016-05-21 06:43:08"><h4 class="wnContent headline"><a href="/story/32030625/hometown-proud-agricultural-manufacturing-company-in-moxee-is-worldwide"><span class="text">HOMETOWN PROUD: Agricultural manufacturing company in Moxee is worldwide</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/32030625/hometown-proud-agricultural-manufacturing-company-in-moxee-is-worldwide"><span class="text">HOMETOWN PROUD: Agricultural manufacturing company in Moxee is worldwide</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Saturday, May 21 2016 2:43 AM EDT</span><span class="wnContent timestamp gmttime">2016-05-21 06:43:08 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/32030625/hometown-proud-agricultural-manufacturing-company-in-moxee-is-worldwide"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10609500_G.jpg?auto=webp&amp;disable=upscale&amp;width=650" title="Berry Harvester from Blueline Manufacturing" alt="Berry Harvester from Blueline Manufacturing"></a><span class="caption left width90"><span class="text">Berry Harvester from Blueline Manufacturing</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/32030625/hometown-proud-agricultural-manufacturing-company-in-moxee-is-worldwide"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10609500_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text">Moxee, WA - Moxee is home to a special manufacturing facility, Blueline Manufacturing, creates equipment that&nbsp;makes a farmers job a whole lot easier, and their customer base, reaches around&nbsp;the world.  Blueline Manufacturing facility takes up an entire city block in Moxee, it's a city staple that's been around for decades. Specializing in&nbsp;designing and building equipment for orchards, vineyards, and general agriculture, Blueline knows&nbsp;all about the making the right...</span><a class="more" href="/story/32030625/hometown-proud-agricultural-manufacturing-company-in-moxee-is-worldwide"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text">Moxee, WA - Moxee is home to a special manufacturing facility, Blueline Manufacturing, creates equipment that&nbsp;makes a farmers job a whole lot easier, and their customer base, reaches around&nbsp;the world.  Blueline Manufacturing facility takes up an entire city block in Moxee, it's a city staple that's been around for decades. Specializing in&nbsp;designing and building equipment for orchards, vineyards, and general agriculture, Blueline knows&nbsp;all about the making the right...</span><a class="more" href="/story/32030625/hometown-proud-agricultural-manufacturing-company-in-moxee-is-worldwide"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station23 story priority-26 even even-4"><meta content="Station 23"><meta content="2016-05-21 05:43:36"><h4 class="wnContent headline"><a href="/story/32030568/hometown-proud-moxee-is-the-hop-capital-and-home-to-a-special-brewery-on-a-hop-farm"><span class="text">HOMETOWN PROUD: Moxee is the hop capital and home to a special brewery on a hop farm</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Saturday, May 21 2016 1:43 AM EDT</span><span class="wnContent timestamp gmttime">2016-05-21 05:43:36 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/32030568/hometown-proud-moxee-is-the-hop-capital-and-home-to-a-special-brewery-on-a-hop-farm"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10609344_G.jpeg?auto=webp&amp;disable=upscale&amp;width=650" title="Bale Breaker Logo" alt="Bale Breaker Logo"></a><span class="caption left width90"><span class="text">Bale Breaker Logo</span></span></div><div class="wnContent summaryImage abridged left width115"><a href="/story/32030568/hometown-proud-moxee-is-the-hop-capital-and-home-to-a-special-brewery-on-a-hop-farm"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10609344_G.jpeg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>Moxee, WA - &nbsp;Nestled in the heart of the Yakima Valley, Moxee is part a region that produces one-third of the world's hops, and is actually one of the top three cities in the region that hugely contributes to that number. &nbsp;Bale Breaker Brewery is a home grown business, and sits in the middle of one of the many hop farms in Moxee.&nbsp;</p> </span><a class="more" href="/story/32030568/hometown-proud-moxee-is-the-hop-capital-and-home-to-a-special-brewery-on-a-hop-farm"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Moxee, WA - &nbsp;Nestled in the heart of the Yakima Valley, Moxee is part a region that produces one-third of the world's hops, and is actually one of the top three cities in the region that hugely contributes to that number. &nbsp;Bale Breaker Brewery is a home grown business, and sits in the middle of one of the many hop farms in Moxee.&nbsp;</p></span><a class="more" href="/story/32030568/hometown-proud-moxee-is-the-hop-capital-and-home-to-a-special-brewery-on-a-hop-farm"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-27 odd odd-4"><meta content="Station 25"><meta content="2016-05-20 21:18:50"><h4 class="wnContent headline"><a href="/story/32028292/hometown-proud-maple-counter-cafe-in-walla-walla-is-known-as-their-local-favorite"><span class="text">HOMETOWN PROUD: Maple Counter Cafe in Walla Walla is known as their local favorite</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/32028292/hometown-proud-maple-counter-cafe-in-walla-walla-is-known-as-their-local-favorite"><span class="text">HOMETOWN PROUD: Maple Counter Cafe in Walla Walla is known as their local favorite</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 20 2016 5:18 PM EDT</span><span class="wnContent timestamp gmttime">2016-05-20 21:18:50 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/32028292/hometown-proud-maple-counter-cafe-in-walla-walla-is-known-as-their-local-favorite"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10605552_G.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/32028292/hometown-proud-maple-counter-cafe-in-walla-walla-is-known-as-their-local-favorite"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10605552_G.png?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>When visiting Walla Walla for our Hometown Proud segment, locals told us there was one stop we absolutely had to make, The Maple Counter Cafe.&nbsp;Apple pancakes, strawberry granola pancakes and oven baked omelets, all can be found at Maple Counter Cafe.&nbsp;</p> </span><a class="more" href="/story/32028292/hometown-proud-maple-counter-cafe-in-walla-walla-is-known-as-their-local-favorite"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>When visiting Walla Walla for our Hometown Proud segment, locals told us there was one stop we absolutely had to make, The Maple Counter Cafe.&nbsp;Apple pancakes, strawberry granola pancakes and oven baked omelets, all can be found at Maple Counter Cafe.&nbsp;</p></span><a class="more" href="/story/32028292/hometown-proud-maple-counter-cafe-in-walla-walla-is-known-as-their-local-favorite"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-28 even even-4"><meta content="Station 25"><meta content="2016-05-07 03:04:00"><h4 class="wnContent headline"><a href="/story/31914454/hometown-proud-the-tuxedo-bar-and-grill-in-prescott"><span class="text">HOMETOWN PROUD: The Tuxedo Bar and Grill in Prescott</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/31914454/hometown-proud-the-tuxedo-bar-and-grill-in-prescott"><span class="text">HOMETOWN PROUD: The Tuxedo Bar and Grill in Prescott</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 6 2016 11:04 PM EDT</span><span class="wnContent timestamp gmttime">2016-05-07 03:04:00 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/31914454/hometown-proud-the-tuxedo-bar-and-grill-in-prescott"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10501646_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/31914454/hometown-proud-the-tuxedo-bar-and-grill-in-prescott"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10501646_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>Apart of our hometown proud series, NBC Right Now visited the town gathering spot in Prescott, Washington where we heard there is a must-have cheeseburger.&nbsp;</p> </span><a class="more" href="/story/31914454/hometown-proud-the-tuxedo-bar-and-grill-in-prescott"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>Apart of our hometown proud series, NBC Right Now visited the town gathering spot in Prescott, Washington where we heard there is a must-have cheeseburger.&nbsp;</p></span><a class="more" href="/story/31914454/hometown-proud-the-tuxedo-bar-and-grill-in-prescott"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-29 odd odd-4"><meta content="Station 25"><meta content="2016-05-07 02:49:16"><h4 class="wnContent headline"><a href="/story/31914397/hometown-proud-izzy-the-camel-in-prescott"><span class="text">HOMETOWN PROUD: Izzy the Camel in Prescott</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/31914397/hometown-proud-izzy-the-camel-in-prescott"><span class="text">HOMETOWN PROUD: Izzy the Camel in Prescott</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, May 6 2016 10:49 PM EDT</span><span class="wnContent timestamp gmttime">2016-05-07 02:49:16 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/31914397/hometown-proud-izzy-the-camel-in-prescott"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10501552_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/31914397/hometown-proud-izzy-the-camel-in-prescott"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10501552_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>NBC Right Now is back at it with the hometown proud series. This week, Prescott, Washington was chosen as the town to visit.&nbsp;</p> </span><a class="more" href="/story/31914397/hometown-proud-izzy-the-camel-in-prescott"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>NBC Right Now is back at it with the hometown proud series. This week, Prescott, Washington was chosen as the town to visit.&nbsp;</p></span><a class="more" href="/story/31914397/hometown-proud-izzy-the-camel-in-prescott"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-30 even even-4"><meta content="Station 25"><meta content="2016-04-16 05:30:04"><h4 class="wnContent headline"><a href="/story/31740902/hometown-proud-the-teapot-dome-in-zillah-brings-crowds-from-around-the-world"><span class="text">HOMETOWN PROUD: The Teapot Dome in Zillah Brings Crowds From Around the World</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/31740902/hometown-proud-the-teapot-dome-in-zillah-brings-crowds-from-around-the-world"><span class="text">HOMETOWN PROUD: The Teapot Dome in Zillah Brings Crowds From Around the World</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Saturday, April 16 2016 1:39 AM EDT</span><span class="wnContent timestamp gmttime">2016-04-16 05:39:25 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/31740902/hometown-proud-the-teapot-dome-in-zillah-brings-crowds-from-around-the-world"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10343786_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/31740902/hometown-proud-the-teapot-dome-in-zillah-brings-crowds-from-around-the-world"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10343786_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>This little teapot, short and stout.,&nbsp;was created with scandal in mind.&nbsp;Here is its handle,&nbsp;here is its spout. And it sits in all its handcrafted beauty for people to come to Zillah from far and wide to see and take selfies.&nbsp;</p></span><a class="more" href="/story/31740902/hometown-proud-the-teapot-dome-in-zillah-brings-crowds-from-around-the-world"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>This little teapot, short and stout.,&nbsp;was created with scandal in mind.&nbsp;Here is its handle,&nbsp;here is its spout. And it sits in all its handcrafted beauty for people to come to Zillah from far and wide to see and take selfies.&nbsp;</p></span><a class="more" href="/story/31740902/hometown-proud-the-teapot-dome-in-zillah-brings-crowds-from-around-the-world"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-31 odd odd-4"><meta content="Station 25"><meta content="2016-04-16 05:38:45"><h4 class="wnContent headline"><a href="/story/31740935/hometown-proud-family-owned-restaurant-for-80-years-dishes-out-famous-prime-rib"><span class="text">HOMETOWN PROUD: Family owned restaurant for 80 years dishes out famous prime rib</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/31740935/hometown-proud-family-owned-restaurant-for-80-years-dishes-out-famous-prime-rib"><span class="text">HOMETOWN PROUD: Family owned restaurant for 80 years dishes out famous prime rib</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Saturday, April 16 2016 1:38 AM EDT</span><span class="wnContent timestamp gmttime">2016-04-16 05:38:45 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summary abridged"><span class="text"><p>As soon as you walk into the Squeeze Inn in downtown Zillah, the first thing you see is a piece of history.&nbsp;In fact, so much has happened inside these walls since the family business was opened in the 30's by Rod's grandmother&nbsp;that they have history hanging all over the walls. When's the last time you had a t-bone streak for 2 dollars?</p> </span><a class="more" href="/story/31740935/hometown-proud-family-owned-restaurant-for-80-years-dishes-out-famous-prime-rib"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>As soon as you walk into the Squeeze Inn in downtown Zillah, the first thing you see is a piece of history.&nbsp;In fact, so much has happened inside these walls since the family business was opened in the 30's by Rod's grandmother&nbsp;that they have history hanging all over the walls. When's the last time you had a t-bone streak for 2 dollars?</p></span><a class="more" href="/story/31740935/hometown-proud-family-owned-restaurant-for-80-years-dishes-out-famous-prime-rib"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-32 even even-4"><meta content="Station 25"><meta content="2016-04-09 03:07:38"><h4 class="wnContent headline"><a href="/story/31681413/hometown-proud-lucky-jam-barn-in-stanfield-oregon"><span class="text">HOMETOWN PROUD: Lucky Jam Barn in Stanfield, Oregon</span></a></h4><h4 class="wnContent headline abridged"><a href="/story/31681413/hometown-proud-lucky-jam-barn-in-stanfield-oregon"><span class="text">HOMETOWN PROUD: Lucky Jam Barn in Stanfield, Oregon</span></a></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, April 8 2016 11:21 PM EDT</span><span class="wnContent timestamp gmttime">2016-04-09 03:21:51 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/31681413/hometown-proud-lucky-jam-barn-in-stanfield-oregon"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10290782_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/31681413/hometown-proud-lucky-jam-barn-in-stanfield-oregon"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10290782_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>On Friday, NBC Right Now kicked off a new series, &quot;Hometown Proud&quot;.&nbsp;</p></span><a class="more" href="/story/31681413/hometown-proud-lucky-jam-barn-in-stanfield-oregon"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>On Friday, NBC Right Now kicked off a new series, &quot;Hometown Proud&quot;.&nbsp;</p></span><a class="more" href="/story/31681413/hometown-proud-lucky-jam-barn-in-stanfield-oregon"><span class="text">More >></span></a></div><div class="wnClear"></div></li><li class="wnItem feature Station25 story priority-33 odd odd-4 last"><meta content="Station 25"><meta content="2016-04-09 03:20:23"><h4 class="wnContent headline"><a href="/story/31681479/hometown-proud-fun-fashions-boutique-in-stanfield-oregon"><span class="text">HOMETOWN PROUD: Fun Fashions Boutique in Stanfield, Oregon</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><h4 class="wnContent headline abridged"><a href="/story/31681479/hometown-proud-fun-fashions-boutique-in-stanfield-oregon"><span class="text">HOMETOWN PROUD: Fun Fashions Boutique in Stanfield, Oregon</span></a><span title="Video included" class="wn-icon wn-icon-video-included"></span></h4><div class="timestamps wnDate"><label class="wnContent timestamp lastediteddate">Updated: </label><span class="wnContent timestamp servertime">Friday, April 8 2016 11:20 PM EDT</span><span class="wnContent timestamp gmttime">2016-04-09 03:20:24 GMT</span><span class="wnContent timestamp timeago"></span><span class="wnContent timestamp mytime"></span></div><div class="wnContent summaryImage left width90"><a href="/story/31681479/hometown-proud-fun-fashions-boutique-in-stanfield-oregon"><img border="0" width="90" data-path="http://kndu.images.worldnow.com/images/10290881_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summaryImage abridged left width115"><a href="/story/31681479/hometown-proud-fun-fashions-boutique-in-stanfield-oregon"><img border="0" width="115" data-path="http://kndu.images.worldnow.com/images/10290881_G.jpg?auto=webp&amp;disable=upscale&amp;width=650"></a></div><div class="wnContent summary abridged"><span class="text"><p>In our new series &quot;Hometown Proud&quot;, Stanfield, Oregon was chosen as the first location our NBC Right Now news team would visit.&nbsp;</p> </span><a class="more" href="/story/31681479/hometown-proud-fun-fashions-boutique-in-stanfield-oregon"><span class="text">More >></span></a></div><div class="wnContent summary"><span class="text"><p>In our new series &quot;Hometown Proud&quot;, Stanfield, Oregon was chosen as the first location our NBC Right Now news team would visit.&nbsp;</p></span><a class="more" href="/story/31681479/hometown-proud-fun-fashions-boutique-in-stanfield-oregon"><span class="text">More >></span></a></div><div class="wnClear"></div></li><div class="wnClear"></div></ul><div class="wnClear"></div></div><script>
                var ds = new Worldnow.CustomizedBlock('DisplaySizeId-4');
                Worldnow.EventMan.event('displaysizeloaded',ds)
            </script><!--End of Display Size: Half Horizontal - Col 2 (-4)--><div class="debug hide" data-debug="Display Size 11 attempting to load..."></div><div id="WNAd52" class="wnad wnad52">
<script>wnad_52.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 6 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol2done');</script>
<!--END WNCol2-->
<div id="WNCol23Bottom"><div class="debug hide" data-debug="Display Size 31 attempting to load..."></div><div id="WNAd49" class="wnad wnad49">
<script>wnad_49.load();</script></div>
<!--END wnAdSize-->
<div class="wnClear"></div></div><!--END WNCol23Bottom--></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol23done');</script>
<!--END WNCol23-->
<div id="WNCol4" class="column col4"><!--
                        Column 4 Layout Configuration: 8-->
<div class="debug hide" data-debug="Display Size 76 attempting to load..."></div><section class="block weather simple-a wnclear" id="ID0EELAM"><a class="ribbon" href="/weather">HD DOPPLER 6i</a><div class="left col"><img class="graphic radar" src="http://ftpcontent.worldnow.com/kndu/akamai/images/web_nexrad.gif"></div><div class="right col"><address></address><div><span class="temp"></span></div><div class="sky"></div><div class="hilo"><span class="hi"></span><span> / </span><span class="lo"></span></div></div><div class="links"><a class="link" href="/weather">7-Day Forecast</a><a class="link" href="/category/243789/weather-pictures">Weather Pix</a><a class="link" href="/category/87423/school-closures-and-delays">School Closures</a></div></section><script>
            $(function() {
                var zipcodes = [];
                var $parent = $('section#ID0EELAM');
                var $right = $parent.find('.col.right');
                zipcodes.push('99201');zipcodes.push('83814');
                window.WEATHER_SIMPLE_A_INDEX = -1;
                window.WEATHER_SIMPLE_A_SPEED = 5000;
                var goweather = function() {

                    window.WEATHER_SIMPLE_A_INDEX = (window.WEATHER_SIMPLE_A_INDEX < zipcodes.length) ? window.WEATHER_SIMPLE_A_INDEX + 1 : 0;

                    $right.fadeOut('fast');

                    $.ajax({
                        url: 'http://data-services.wsi.com/200904-01/924342497/Weather/Report/' + zipcodes[window.WEATHER_SIMPLE_A_INDEX]
                        , success: function(data) {
                            data = $.xml2json(data);
                            city = data.City || {};
                            current = city.CurrentObservation || null;
                            daily = city.DailyForecast || {};
                            today = (daily.Day || [])[0] || null;
                            if(current) {
                                var icon = 'http://ftpcontent.worldnow.com/wncustom/wx_icons/wsi55/' + current.IconCode + '.png';
                                $parent.find('address').text(city.Name);
                                $parent.find('.temp').text(current.TempF);
                                $parent.find('img.temp').remove();/* from previous zipcode */
                                $parent.find('.temp').after($('<img class="temp" src="'+icon+'">'));
                                $parent.find('.sky').text(current.Sky);
                                $parent.find('.col.right').fadeIn();
                            }
                            if(today) {
                                $parent.find('.hi').text(today.HiTempF);
                                $parent.find('.lo').text(today.LoTempF);
                            }
                            $right.fadeIn('fast');
                            if(zipcodes.length > 1) {
                                window.setTimeout(goweather,window.WEATHER_SIMPLE_A_SPEED);
                            }
                        }, error : function(e) {
                            $right.fadeIn('fast');
                            console.log(e);
                        }
                    })
                };
                goweather();
            })
        </script><div id="WNAd43" class="wnad wnad43">
<script>wnad_43.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd44" class="wnad wnad44">
<script>wnad_44.load();</script></div>
<!--END wnAdSize-->
<div id="WNAd47" class="wnad wnad47">
<script>wnad_47.load();</script></div>
<!--END wnAdSize-->
<div class="debug hide" data-debug="Display Size 64 attempting to load..."></div><div class="debug hide" data-debug="Display Size 66 attempting to load..."></div></div>
<script type="text/javascript">if (Worldnow.EventMan) Worldnow.EventMan.event('WNCol4done');</script>
<!--END WNCol4-->
<div class="debug hide" data-debug="Display Size 35 attempting to load..."></div><div class="wnClearLeft"></div></div><!--END WNCols23-4--></div><!--END WNCols234-5-->
</div><!--END WNColsAll-->
</section><section class="footer wn-bg-page-footer"><footer class="simple-a row wn-main-a"><div class="flexbox stretch"><div class="flexitem auto search"><h4>Can't Find Something?</h4><form class="search" action="/search" method="get"><input type="hidden" name="vendor" value="ez"><input class="text" type="text" name="qu" size="10" value="" placeholder="Search"><button class="submit wn-accent-a" type="submit">Go</button></form></div><div class="flexitem auto branding" style="background-image:url(http://KNDU.images.worldnow.com/images/static/gfx/nav_top.gif)"></div><div class="flexitem auto contact"></div></div></footer></section><section class="nav wn-bg-page-nav"><nav class="simple-a main count-8 flexbox"><a data-id="76086" class="wn-main-a flexitem auto" href="/" target="">Home</a><a data-id="76089" class="wn-main-a flexitem auto" href="/category/76089/news" target="">News</a><a data-id="76087" class="wn-main-a flexitem auto" href="/weather" target="">Weather</a><a data-id="189473" class="wn-main-a flexitem auto" href="/category/189473/video-center" target="">Video Center</a><a data-id="327188" class="wn-main-a flexitem auto" href="/category/327188/sports" target="">Sports </a><a data-id="76091" class="wn-main-a flexitem auto" href="/category/76091/community" target="">Community</a><a data-id="259182" class="wn-main-a flexitem auto" href="/category/259182/check-it-out" target="">Check It Out</a><a data-id="78221" class="wn-main-a flexitem auto" href="/category/78221/contact-us" target="">Contact Us</a></nav><script>
            $(function(){
                if(window.simpleMenuALoaded) return;
                var $body = $('body');
                var $columns = $('#WNCols234-5')
                var wipe = function() {
                    $body.removeClass(function (index, css) {
                        return (css.match (/(^|\s)nav-\S+/g) || []).join(' ');
                    });
                }
                $('nav.simple-a.main:first a').each(function() {
                    var $$ = $(this)
                    $$.on('hover',function() {
                        wipe()
                        $body.addClass('nav-feature-' + $$.data('id'))
                    })
                });
                $columns.on('mouseenter',wipe);
                window.simpleMenuALoaded = true;
            });
        </script></section><section class="footer wn-bg-page-worldnow"><footer class="worldnow row wn-accent-a"><p>
                    All content © Copyright 2000 - 2018 <a href="http://www.worldnow.com" target="_new">Frankly Media</a> and <span class="clientname" data-brandname="" data-clientname="kndu"></span>. All Rights Reserved. For more information on this site, please read our <a href="/global/story.asp?s=18990">Privacy Policy</a>, <a href="/global/story.asp?s=18991">Terms of Service</a>, and <a target="policy" href="http://www.aboutads.info/choices/">Ad Choices</a>.
                </p></footer></section>
<!--
                Page Include: BODY--><script language="JavaScript">var zflag_nid="1805"; var zflag_cid="1"; var zflag_sid="0"; var zflag_width="160"; var zflag_height="600"; var zflag_sz="7"; </script><script language="JavaScript" src="http://c5.zedo.com/jsc/c5/fhs.js"></script><!-- Quantcast Tag --><script type="text/javascript">var _qevents = _qevents || [];(function() {var elem = document.createElement('script');elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";elem.async = true;elem.type = "text/javascript";var scpt = document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem, scpt);})();_qevents.push({qacct:"p-6c3kpfRrvakY0"});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-6c3kpfRrvakY0.gif" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><!-- End Quantcast tag --><!--
                END Page Include: BODY-->
<!--Customized Page Includes - Body--><script src="//cdn.jsdelivr.net/jquery.slick/1.5.6/slick.min.js"></script>
<script>(function(w){ var e = w.EventMan || null; var b = w.Beacon || null; e.event('analytics-body',b.get('page')); })(window.Worldnow || {});</script>
<script type="text/javascript">
                    if(Worldnow.EventMan){Worldnow.EventMan.event('bodydone');}
                </script></body></html>